popt.spec 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. %{expand:%%global _pkgconfigdir %{_libdir}/pkgconfig}
  2. %define _libdir /%{_lib}
  3. Summary: A C library for parsing command line parameters.
  4. Name: popt
  5. Version: 1.16
  6. Release: 1
  7. License: X Consortium
  8. Group: System Environment/Libraries
  9. Source: http://rpm5.org/files/popt/%{name}-%{version}.tar.gz
  10. BuildRequires: gettext
  11. BuildRoot: %{_tmppath}/%{name}-root
  12. %description
  13. Popt is a C library for parsing command line parameters. Popt was
  14. heavily influenced by the getopt() and getopt_long() functions, but it
  15. improves on them by allowing more powerful argument expansion. Popt
  16. can parse arbitrary argv[] style arrays and automatically set
  17. variables based on command line arguments. Popt allows command line
  18. arguments to be aliased via configuration files and includes utility
  19. functions for parsing arbitrary strings into argv[] arrays using
  20. shell-like rules.
  21. %prep
  22. %setup -q
  23. %build
  24. %configure
  25. make
  26. %install
  27. rm -rf $RPM_BUILD_ROOT
  28. make DESTDIR=$RPM_BUILD_ROOT install
  29. %find_lang popt
  30. %check
  31. make check || :
  32. %track
  33. prog popt = {
  34. version = %{version}
  35. url = http://rpm5.org/%{name}
  36. regex = %{name}-(\d+\.\d+\.\d+)\.tar\.gz
  37. }
  38. %clean
  39. rm -rf $RPM_BUILD_ROOT
  40. %files -f popt.lang
  41. %defattr(-,root,root)
  42. %{_libdir}/libpopt.*
  43. %{_includedir}/popt.h
  44. %{_mandir}/man3/popt.3*
  45. %{_pkgconfigdir}/popt.pc
  46. %changelog
  47. * Wed Feb 17 2010 Jeff Johnson <jbj@rpm5.org>
  48. - release popt-1.16 through rpm5.org.
  49. * Fri Apr 10 2009 Jeff Johnson <jbj@rpm5.org>
  50. - release popt-1.15 through rpm5.org.
  51. * Tue Dec 11 2007 Jeff Johnson <jbj@rpm5.org>
  52. - release popt-1.13 through rpm5.org.
  53. * Tue Jul 10 2007 Jeff Johnson <jbj@rpm5.org>
  54. - release popt-1.12 through rpm5.org.
  55. * Sat Jun 9 2007 Jeff Johnson <jbj@rpm5.org>
  56. - release popt-1.11 through rpm5.org.
  57. * Thu Dec 10 1998 Michael Johnson <johnsonm@redhat.com>
  58. - released 1.2.2; see CHANGES
  59. * Tue Nov 17 1998 Michael K. Johnson <johnsonm@redhat.com>
  60. - added man page to default install
  61. * Thu Oct 22 1998 Erik Troan <ewt@redhat.com>
  62. - see CHANGES file for 1.2
  63. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  64. - added ./configure step to spec file